A-A+

华为交换机链路聚合配置

2019年06月26日 技术分享, 电脑网络 暂无评论 阅读 185 次

说到链路聚合,涂涂想起了一件很扯的事儿,就是2019年5月10日,我在红光小学实施按校方要求将新增B区办公网监控网与A区主干网互通配置时,由于A区主干网是重庆市内一家公司做的其设备均配置了管理密码,重庆方又不愿意给,路由器及核心交换机皆在A区中心机房,B区汇聚交换机有两台及下接入层交换机需要互通都要经过A区交换机路由器,B区交换机A单光纤25口接入核心交换机17口,交换机B交换机25口接入核心交换机18口,主要设备均是锐捷产品。

1.物理上交换机光纤相连,本人验光笔测试光芯通对端见光,两条均无异常。

2.光纤模块新的两对分别于A,B区如上所述接口上,接口指示灯不亮。

分析:线是通的光通,模块符合要求(因为我测试了将模块换到原本正在传输数据的接口上,亮灯了)但是就是不亮灯。

大家猜猜重庆实施方工程师咋说,他说我B区交换机,没有配置链路聚合,说:你不配置链路聚合,这一辈子我这两条链路的灯都不会亮!天啊,晴天霹雳,就目前物理上灯都不亮,是我没做链路聚合的缘故吗?扯淡吧,我心想。况且,我B区汇聚交换机单机单线接入核心交换机符合链路聚合条件吗?我想问。

对方态度强硬坚决,我又苦于没有前端中心机房主体设备管理密码,不能登入设备进行故障排查及诊断,但我可以肯定我的线路模块及我B区设备配置是正确无误的,总得按校方要求内外网都互通吧,一打电话对方极不耐烦的说你先把链路聚合配好再说,简直那个纳闷啊,没办法,我先冷静冷静后,低声细语哥前哥后的,让这位大哥配合我,我将核心交换机接入口转14与16口,让这位高人在核心交换机我所启用我接入的接口所对应的vlan允许我汇聚层相应VLAN通过,接口灯亮了,AB区内外网互通,汇报校方后闪人。

导读:有关LACP理,请参看LACP技术白皮书。

1、LACP报文主要字段介绍:
  Actor_Port/Partner_Port:本端/对端接口信息。
  Actor_State/Partner_State:本端/对端状态。
  Actor_System_Priority/Partner_System_Priority:本端/对端系统优先级。
  Actor_System/Partner_System:本端/对端系统ID。
  Actor_Key/Partner_Key:本端/对端操作Key,各接口的该值相同才能够聚合。
  Actor_Port_Priority/Partner_Port_Priority:本端/对端接口优先级。

2、手工负载分担模式链路聚合
  1)手工汇聚概述
  手工负载分担模式是一种最基本的链路聚合方式,在该模式下,Eth-Trunk 接口的建立,成员接口的加入完全由手工来配置,没有链路聚合控制协议的参与。该模式下所有成员接口(selected)都参与数据的转发,分担负载流量,因此称为手工负载分担模式。手工汇聚端口的 LACP 协议为关闭状态,禁止用户使能手工汇聚端口的LACP 协议。
  2) 手工汇聚组中的端口状态
  在手工汇聚组中,端口可能处于两种状态:Selected 或Standby。处于Selected 状态且端口号最小的端口为汇聚组的主端口,其他处于Selected 状态的端口为汇聚组的成员端口。由于设备所能支持的汇聚组中的最大端口数有限制,如果处于Selected 状态的端口数超过设备所能支持的汇聚组中的最大端口数,系统将按照端口号从小到大的顺序选择一些端口为Selected 端口,其他则为Standby 端口。
  3)手工汇聚对端口配置的要求
  一般情况下,手工汇聚对汇聚前的端口速率和双工模式不作限制。但对于以下情况,系统会作特殊处理:
  对于初始就处于 DOWN 状态的端口,在汇聚时对端口的速率和双工模式没有限制;
  对于曾经处于 UP 状态,并协商或强制指定过端口速率和双工模式,而当前处于DOWN 状态的端口,在汇聚时要求速率和双工模式一致;
  对于一个汇聚组,当汇聚组中某个端口的速率和双工模式发生改变时,系统不进行解汇聚,汇聚组中的端口也都处于正常工作状态。但如果是主端口出现速率降低和双工模式变化,则该端口的转发可能出现丢包现象。

一、配置手工负载分担模式链路聚合LACP示例
  

[Huawei]sysname SWA 配置交换机主机名

[SWA]

Jun 26 2019 09:55:18-08:00 SWA DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25.191.3.1 configurations have been changed. The current change number is 4, the change loop count is 0, and the maximum number of records is 4095.

[SWA]undo info-center enable 关闭配置变更提示信息

Info: Information center is disabled.

[SWA]vlan batch 1000 这里假设两聚合设备之间只放行vlan1000

[SWA]interface Eth-Trunk 0 创建聚合

[SWA-Eth-Trunk0]mode manual load-balance 设定聚合模式为手工负载分摊模式,当然也可不设置默认为手工模式

[SWA-Eth-Trunk0]trunkport GigabitEthernet 0/0/1 0/0/2 根据实际情况加入需要聚合的物理端口

[SWA-Eth-Trunk0]least active-linknumber 1 配置链路聚合活动接口数下限阀值

[SWA-Eth-Trunk0]load-balance ? 以下为支持的所有负载分摊方式

dst-ip According to destination IP hash arithmetic

dst-mac According to destination MAC hash arithmetic

src-dst-ip According to source/destination IP hash arithmetic

src-dst-mac According to source/destination MAC hash arithmetic

src-ip According to source IP hash arithmetic

src-mac According to source MAC hash arithmetic

[SWA-Eth-Trunk0]load-balance src-dst-ip 此为负载分摊方式的默认配置,也可不配置

[SWA-Eth-Trunk0]port link-type trunk 配置接口为trunk类型

[SWA-Eth-Trunk0]port trunk allow-pass vlan 1000 配置允许vlan 1000通过

[SWA-Eth-Trunk0]undo port trunk allow-pass vlan 1 配置删除默认可通过的VLAN 1

至此交换SWA配置完成,交换机SWB相同,注意交换机SWB请将相应端口加入eth-trunk中。

[SWA]display eth-trunk 0 查看配置情况

[SWA]interface Ethernet 0/0/1 进入接口

[SWA-Ethernet0/0/1]port link-type access 配置连接PC主机接口类型为access

[SWA-Ethernet0/0/1]port default vlan 1000 将交换机接口对应PC划分至VLAN

[SWA-Ethernet0/0/1]quit

[SWA]quit

<SWA>save 保存配置

二、配置静态LACP模式链路聚合
配置思路

采用如下的思路配置静态LACP模式链路聚合:

  1. Switch设备上创建Eth-Trunk,配置Eth-Trunk为静态LACP模式。
  2. 将成员接口加入Eth-Trunk。
  3. 配置系统优先级确定主动端。
  4. 配置活动接口上限阈值。
  5. 配置接口优先级确定活动链路。
数据准备

为完成此配置例,需准备如下的数据:

  1. 两端Switch设备链路聚合组编号。
  2. SWA系统优先级。
  3. 活动接口上限阈值。
  4. 活动接口LACP优先级。
配置步骤

创建编号为1的Eth-Trunk,配置它的工作模式为静态LACP模式

# 配置SWA

[SWA]interface Eth-Trunk 1 创建聚合口为eth-trunk1

[SWA-Eth-Trunk1]bpdu enable 配置接口Eth-Trunk 处理BPDU 报文

[SWA-Eth-Trunk1]mode lacp-static 配置它的工作模式为静态LACP模式

[SWA-Eth-Trunk1]quit

# 配置SWB

[SWB]interface Eth-Trunk 1 创建聚合口为eth-trunk1

[SWB-Eth-Trunk1]bpdu enable 配置接口Eth-Trunk 处理BPDU 报文

[SWB-Eth-Trunk1]mode lacp-static 配置它的工作模式为静态LACP模式

[SWB-Eth-Trunk1]quit

将成员接口加入Eth-Trunk

# 配置SWA

[SWA]interface Ethernet 0/0/20

[SWA-Ethernet0/0/20]eth-trunk 1

[SWA-Ethernet0/0/20]quit

[SWA]interface Ethernet 0/0/21

[SWA-Ethernet0/0/21]eth-trunk 1

[SWA-Ethernet0/0/21]quit

[SWA]interface Ethernet 0/0/22

[SWA-Ethernet0/0/22]eth-trunk 1

[SWA-Ethernet0/0/22]quit

# 配置SWB

[SWB]interface Ethernet 0/0/20

[SWB-Ethernet0/0/20]eth-trunk 1

[SWB-Ethernet0/0/20]quit

[SWB]interface Ethernet 0/0/21

[SWB-Ethernet0/0/21]eth-trunk 1

[SWB-Ethernet0/0/21]quit

[SWB]interface Ethernet 0/0/22

[SWB-Ethernet0/0/22]eth-trunk 1

[SWB-Ethernet0/0/22]quit

# 在SWA上配置系统优先级为100,使其成为LACP主动端

[SWA] lacp priority 100

# 在SWA上配置活动接口上限阈值为2

[SWA] interface eth-trunk 1

[SWA-Eth-Trunk1] max active-linknumber 2

[SWA-Eth-Trunk1] quit

# 在SWA上配置接口优先级确定活动链路

[SWA] interface ethernet 0/0/20

[SWA-Ethernet0/0/1] lacp priority 100

[SWA-Ethernet0/0/1] quit

[SWA] interface ethernet 0/0/21

[SWA-Ethernet0/0/2] lacp priority 100

[SWA-Ethernet0/0/2] quit

# 查看各Switch设备的Eth-Trunk信息,查看链路是否协商成功。

[SWA]display eth-trunk 1

通过以上显示信息可以看到,SWA的系统优先级为100,高于SWB的系统优先级。Eth-Trunk的成员接口中Ethernet 0/0/20、Ethernet 0/0/21成为活动接口,处于“Selected”状态,接口Ethernet 0/0/22处于“Unselect”状态,同时实现M条链路的负载分担和N条链路的冗余备份功能。

# 如果交换机WSA,B需要划分VLAN

[SWA]vlan batch 1001

[SWA]interface Ethernet 0/0/1

[SWA-Ethernet0/0/1]port link-type access

[SWA-Ethernet0/0/1]port default vlan 1001

[SWA-Ethernet0/0/1]quit

[SWA]interface Eth-Trunk 1

[SWA-Eth-Trunk1]port link-type trunk

[SWA-Eth-Trunk1]port trunk allow-pass vlan 1001

[SWA-Eth-Trunk1]quit

# 配置SWB

[SWB]vlan batch 1001

[SWB]interface Ethernet 0/0/1

[SWB-Ethernet0/0/1]port link-type access

[SWB-Ethernet0/0/1]port default vlan 1001

[SWB-Ethernet0/0/1]quit

[SWB]interface Eth-Trunk 1

[SWB-Eth-Trunk1]port link-type trunk

[SWB-Eth-Trunk1]port trunk allow-pass vlan 1001

[SWB-Eth-Trunk1]quit

说明: LACP优先级值越大,优先级越低,系统LACP优先级为32768

给我留言

icon_question icon_razz icon_sad icon_evil icon_exclaim icon_smile icon_redface icon_biggrin icon_surprised icon_eek icon_confused icon_cool icon_lol icon_mad icon_liuhan icon_rolleyes icon_wink icon_idea icon_arrow icon_neutral icon_cry icon_mrgreen icon_qinqin icon_bizui

×
订阅图标按钮